==>(B Building on rapidash(B ==>(B Checking for remote environment...(B ==>(B Syncing package to remote host...(B sending incremental file list ./ .SRCINFO 700B 96% 0B/s 0:00:00 729B 100% 29,000B/s 0:00:00 (xfr#1, to-chk=7/9) .nvchecker.toml 91B 100% 91,000B/s 0:00:00 91B 100% 91,000B/s 0:00:00 (xfr#2, to-chk=6/9) LICENSE 646B 100% 646,000B/s 0:00:00 646B 100% 646,000B/s 0:00:00 (xfr#3, to-chk=5/9) PKGBUILD 700B 42% 700,000B/s 0:00:00 1,633B 100% 1,633,000B/s 0:00:00 (xfr#4, to-chk=4/9) REUSE.toml 375B 100% 375,000B/s 0:00:00 375B 100% 375,000B/s 0:00:00 (xfr#5, to-chk=3/9) python-pysnmp-7.1.30-1.log 820B 100% 820,000B/s 0:00:00 820B 100% 820,000B/s 0:00:00 (xfr#6, to-chk=2/9) LICENSES/ sent 1,257 bytes received 210 bytes 586.80 bytes/sec total size is 3,691 speedup is 2.52 ==>(B Applying RISC-V patches...(B sending incremental file list ./ sent 119 bytes received 19 bytes 92.00 bytes/sec total size is 16,904 speedup is 122.49 patching file PKGBUILD ==>(B Running pkgctl build --arch riscv64 on remote host...(B ==> WARNING:(B invalid architecture: riscv64(B ==>(B Updating pacman database cache(B ==>(B Locking pacman database cache...(Bdone(B [?25l:: Synchronizing package databases... core downloading... extra downloading... multilib downloading... [?25h==>(B Building python-pysnmp(B ==>(B Locking pacman database cache...(Bdone(B  ->(B repo: extra(B  ->(B arch: riscv64(B  ->(B worker: felix-9(B ==>(B Building python-pysnmp for [extra] (riscv64)(B ]3008;start=c6e961ffe57348ef89500214495967c7;user=felix;hostname=rapidash.felixc.at;machineid=8416a3f6c64d4985b238a9c57e532efe;bootid=257ed0d46a43490f9d4b7d4237a96b33;pid=175677;pidfdid=63092683;comm=sudo;targetuser=root;type=session\==>(B Locking clean chroot...(Bdone(B Note: in a future version of systemd-nspawn the default set of permitted socket address families will be restricted to AF_INET, AF_INET6 and AF_UNIX. Use --restrict-address-families= to configure the set of permitted socket address families, or set RestrictAddressFamilies= in a .nspawn file. ]3008;start=824d0dd4701348ceba54e76afbaf4c81;user=root;hostname=rapidash.felixc.at;machineid=8416a3f6c64d4985b238a9c57e532efe;bootid=257ed0d46a43490f9d4b7d4237a96b33;pid=187414;pidfdid=63059093;comm=systemd-nspawn;container=arch-nspawn-187414;type=container\]11;?\]2;🔵 Container arch-nspawn-187414 on rapidash.felixc.at\[?25l:: Synchronizing package databases... core downloading... extra downloading... :: Starting full system upgrade... there is nothing to do [?25h[!p]104\[?7h]3008;end=824d0dd4701348ceba54e76afbaf4c81\==>(B Building in chroot for [extra] (riscv64)...(B ==>(B Locking clean chroot [/var/lib/archbuild/extra-riscv64/root]...(Bdone(B ==>(B Synchronizing chroot copy [/var/lib/archbuild/extra-riscv64/root] -> [felix-9]...(Bdone(B ]3008;start=c1c17cb6d5d0436d91423d293390f22c;user=root;hostname=rapidash.felixc.at;machineid=8416a3f6c64d4985b238a9c57e532efe;bootid=257ed0d46a43490f9d4b7d4237a96b33;pid=198652;pidfdid=63148485;comm=sudo;targetuser=felix;type=session\==>(B Making package: python-pysnmp 7.1.30-1 (Tue Oct 20 13:19:06 2026)(B ==>(B Retrieving sources...(B  ->(B Found pysnmp-v7.1.30.tar.gz(B  ->(B Found local-test-agent.patch(B ==>(B Validating source files with sha512sums...(B pysnmp-v7.1.30.tar.gz ... Passed local-test-agent.patch ... Passed ]3008;end=c1c17cb6d5d0436d91423d293390f22c\Note: in a future version of systemd-nspawn the default set of permitted socket address families will be restricted to AF_INET, AF_INET6 and AF_UNIX. Use --restrict-address-families= to configure the set of permitted socket address families, or set RestrictAddressFamilies= in a .nspawn file. ]3008;start=523c73245ab74561a8342e8f4d0b846c;user=root;hostname=rapidash.felixc.at;machineid=8416a3f6c64d4985b238a9c57e532efe;bootid=257ed0d46a43490f9d4b7d4237a96b33;pid=200403;pidfdid=63126554;comm=systemd-nspawn;container=makechrootpkg-python-pysnmp.build.175790;type=container\]11;?\]2;🔵 Container makechrootpkg-python-pysnmp.build.175790 on rapidash.felixc.at\]3008;start=615d05ee038b4f22b7b3059d60fd5a1d;user=root;hostname=makechrootpkg-python-pysnmp.build.175790;machineid=4361284f915442ca98e33558d466872a;bootid=3f7c1d038fb44a23a52318b311dde1e8;pid=34;pidfdid=63037081;comm=sudo;targetuser=builduser;type=session\==>(B Making package: python-pysnmp 7.1.30-1 (Tue Oct 20 13:19:16 2026)(B ==>(B Checking runtime dependencies...(B ==>(B Installing missing dependencies...(B ]3008;start=1749b61a3a86484cb5c1aca326bd252f;user=builduser;hostname=makechrootpkg-python-pysnmp.build.175790;machineid=4361284f915442ca98e33558d466872a;bootid=3f7c1d038fb44a23a52318b311dde1e8;pid=2012;pidfdid=63029104;comm=sudo;targetuser=root;type=session\[?25lresolving dependencies... looking for conflicting packages... Package (14) New Version Net Change Download Size extra/python-certifi 2026.10.18-1 0.02 MiB extra/python-cffi 2.1.1-1 1.41 MiB extra/python-charset-normalizer 3.5.1-1 0.63 MiB extra/python-idna 3.20-1 0.68 MiB extra/python-jinja 1:3.1.6-3.1 2.04 MiB extra/python-lark-parser 1.3.1-2 1.39 MiB extra/python-markupsafe 3.0.4-1 0.09 MiB extra/python-pycparser 3.11-1 0.74 MiB 0.11 MiB extra/python-requests 2.34.2-1 0.76 MiB extra/python-typing_extensions 4.16.0-1 0.53 MiB extra/python-urllib3 2.8.0-1 1.48 MiB extra/python-cryptography 50.0.2-1 6.50 MiB extra/python-pyasn1 0.6.4-1 1.23 MiB extra/python-pysmi 2.0.0-2.1 0.93 MiB Total Download Size: 0.11 MiB Total Installed Size: 18.42 MiB :: Proceed with installation? [Y/n] :: Retrieving packages... python-pycparser-3.11-1-any downloading... checking keyring... checking package integrity... loading package files... checking for file conflicts... :: Processing package changes... installing python-pycparser... installing python-cffi... Optional dependencies for python-cffi python-setuptools: "limited api" version checking in cffi.setuptools_ext installing python-cryptography... installing python-pyasn1... installing python-markupsafe... installing python-jinja... Optional dependencies for python-jinja python-babel: for i18n support installing python-typing_extensions... installing python-lark-parser... Optional dependencies for python-lark-parser python-atomicwrites: for atomic_cache python-regex: for regex support installing python-charset-normalizer... installing python-idna... installing python-urllib3... Optional dependencies for python-urllib3 python-brotli: Brotli support python-brotlicffi: Brotli support python-h2: HTTP/2 support python-pysocks: SOCKS support installing python-certifi... installing python-requests... Optional dependencies for python-requests python-chardet: alternative character encoding library python-pysocks: SOCKS proxy support installing python-pysmi... :: Running post-transaction hooks... (1/1) Arming ConditionNeedsUpdate... [?25h]3008;end=1749b61a3a86484cb5c1aca326bd252f\==>(B Checking buildtime dependencies...(B ==>(B Installing missing dependencies...(B ]3008;start=acef196ac1784c61badb790b7f264aba;user=builduser;hostname=makechrootpkg-python-pysnmp.build.175790;machineid=4361284f915442ca98e33558d466872a;bootid=3f7c1d038fb44a23a52318b311dde1e8;pid=2248;pidfdid=63134376;comm=sudo;targetuser=root;type=session\[?25lresolving dependencies... looking for conflicting packages... Package (11) New Version Net Change extra/python-iniconfig 2.3.0-1 0.07 MiB extra/python-packaging 26.3-1 1.58 MiB extra/python-pluggy 1.7.0-1 0.28 MiB extra/python-pygments 2.21.0-1 15.59 MiB extra/python-pyproject-hooks 1.3.3-1 0.11 MiB extra/python-build 1.6.1-1 0.33 MiB extra/python-flit-core 4.1.0-1 0.38 MiB extra/python-installer 1.1.0-1 0.21 MiB extra/python-pytest 1:9.1.1-1 4.95 MiB extra/python-pytest-asyncio 1.4.0-1 0.17 MiB extra/python-wheel 0.48.0-1 0.34 MiB Total Installed Size: 24.00 MiB :: Proceed with installation? [Y/n] checking keyring... checking package integrity... loading package files... checking for file conflicts... :: Processing package changes... installing python-packaging... installing python-pyproject-hooks... installing python-build... Optional dependencies for python-build python-pip: to use as the Python package installer (default) python-uv: to use as the Python package installer python-virtualenv: to use virtualenv for build isolation installing python-flit-core... installing python-installer... installing python-wheel... Optional dependencies for python-wheel python-keyring: for wheel.signatures python-xdg: for wheel.signatures python-setuptools: for legacy bdist_wheel subcommand installing python-iniconfig... installing python-pluggy... installing python-pygments... installing python-pytest... installing python-pytest-asyncio... :: Running post-transaction hooks... (1/1) Arming ConditionNeedsUpdate... [?25h]3008;end=acef196ac1784c61badb790b7f264aba\==>(B Retrieving sources...(B  ->(B Found pysnmp-v7.1.30.tar.gz(B  ->(B Found local-test-agent.patch(B ==> WARNING:(B Skipping all source file integrity checks.(B ==>(B Extracting sources...(B  ->(B Extracting pysnmp-v7.1.30.tar.gz with bsdtar(B ==>(B Starting prepare()...(B patching file tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py patching file tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulk.py patching file tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py patching file tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py ==>(B Starting build()...(B * Getting build dependencies for wheel... * Building wheel... Successfully built pysnmp-7.1.30-py3-none-any.whl ==>(B Starting check()...(B Source MIB repositories: file:///usr/share/snmp/mibs, https://mibs.pysnmp.com/asn1/@mib@ Borrow missing/failed MIBs from: https://mibs.pysnmp.com:443/mibs/fulltexts/@mib@ Existing/compiled MIB locations: pysnmp.smi.mibs, pysnmp_mibs Compiled MIBs destination directory: /build/.pysnmp/mibs MIBs excluded from code generation: INET-ADDRESS-MIB, PYSNMP-USM-MIB, RFC-1212, RFC-1215, RFC1065-SMI, RFC1155-SMI, RFC1158-MIB, RFC1213-MIB, SNMP-FRAMEWORK-MIB, SNMP-TARGET-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC, SNMPv2-TM, TRANSPORT-ADDRESS-MIB MIBs to compile: NET-SNMP-EXAMPLES-MIB Destination format: pysnmp Custom destination template: None Parser grammar cache directory: not used Also compile all relevant MIBs: yes Rebuild MIBs regardless of age: no Dry run mode: no Create/update MIBs: yes Byte-compile Python modules: yes (optimization level no) Ignore compilation errors: no Generate OID->MIB index: no Generate texts in MIBs: yes Keep original texts layout: no Try various file names while searching for MIB module: yes Missing source MIBs: Ignored MIBs: Failed MIBs: Created/updated MIBs: NET-SNMP-EXAMPLES-MIB, NET-SNMP-MIB Pre-compiled MIBs borrowed: Up to date MIBs: INET-ADDRESS-MIB, SNMP-FRAMEWORK-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC Source MIB repositories: file:///usr/share/snmp/mibs, https://mibs.pysnmp.com/asn1/@mib@ Borrow missing/failed MIBs from: https://mibs.pysnmp.com:443/mibs/fulltexts/@mib@ Existing/compiled MIB locations: pysnmp.smi.mibs, pysnmp_mibs Compiled MIBs destination directory: /build/.pysnmp/mibs MIBs excluded from code generation: INET-ADDRESS-MIB, PYSNMP-USM-MIB, RFC-1212, RFC-1215, RFC1065-SMI, RFC1155-SMI, RFC1158-MIB, RFC1213-MIB, SNMP-FRAMEWORK-MIB, SNMP-TARGET-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC, SNMPv2-TM, TRANSPORT-ADDRESS-MIB MIBs to compile: IF-MIB Destination format: pysnmp Custom destination template: None Parser grammar cache directory: not used Also compile all relevant MIBs: yes Rebuild MIBs regardless of age: no Dry run mode: no Create/update MIBs: yes Byte-compile Python modules: yes (optimization level no) Ignore compilation errors: no Generate OID->MIB index: no Generate texts in MIBs: yes Keep original texts layout: no Try various file names while searching for MIB module: yes Missing source MIBs: Ignored MIBs: Failed MIBs: Created/updated MIBs: IANAifType-MIB, IF-MIB, SNMPv2-MIB Pre-compiled MIBs borrowed: Up to date MIBs: SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC Source MIB repositories: file:///usr/share/snmp/mibs, https://mibs.pysnmp.com/asn1/@mib@ Borrow missing/failed MIBs from: https://mibs.pysnmp.com:443/mibs/fulltexts/@mib@ Existing/compiled MIB locations: pysnmp.smi.mibs, pysnmp_mibs Compiled MIBs destination directory: /build/.pysnmp/mibs MIBs excluded from code generation: INET-ADDRESS-MIB, PYSNMP-USM-MIB, RFC-1212, RFC-1215, RFC1065-SMI, RFC1155-SMI, RFC1158-MIB, RFC1213-MIB, SNMP-FRAMEWORK-MIB, SNMP-TARGET-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC, SNMPv2-TM, TRANSPORT-ADDRESS-MIB MIBs to compile: LEXTUDIO-TEST-MIB Destination format: pysnmp Custom destination template: None Parser grammar cache directory: not used Also compile all relevant MIBs: yes Rebuild MIBs regardless of age: no Dry run mode: no Create/update MIBs: yes Byte-compile Python modules: yes (optimization level no) Ignore compilation errors: no Generate OID->MIB index: no Generate texts in MIBs: yes Keep original texts layout: no Try various file names while searching for MIB module: yes Missing source MIBs: Ignored MIBs: Failed MIBs: Created/updated MIBs: LEXTUDIO-TEST-MIB Pre-compiled MIBs borrowed: Up to date MIBs: SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC Source MIB repositories: file:///usr/share/snmp/mibs, https://mibs.pysnmp.com/asn1/@mib@ Borrow missing/failed MIBs from: https://mibs.pysnmp.com:443/mibs/fulltexts/@mib@ Existing/compiled MIB locations: pysnmp.smi.mibs, pysnmp_mibs Compiled MIBs destination directory: /build/.pysnmp/mibs MIBs excluded from code generation: INET-ADDRESS-MIB, PYSNMP-USM-MIB, RFC-1212, RFC-1215, RFC1065-SMI, RFC1155-SMI, RFC1158-MIB, RFC1213-MIB, SNMP-FRAMEWORK-MIB, SNMP-TARGET-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC, SNMPv2-TM, TRANSPORT-ADDRESS-MIB MIBs to compile: CISCO-ENHANCED-IPSEC-FLOW-MIB Destination format: pysnmp Custom destination template: None Parser grammar cache directory: not used Also compile all relevant MIBs: yes Rebuild MIBs regardless of age: no Dry run mode: no Create/update MIBs: yes Byte-compile Python modules: yes (optimization level no) Ignore compilation errors: no Generate OID->MIB index: no Generate texts in MIBs: yes Keep original texts layout: no Try various file names while searching for MIB module: yes Missing source MIBs: Ignored MIBs: Failed MIBs: Created/updated MIBs: CISCO-ENHANCED-IPSEC-FLOW-MIB, CISCO-IPSEC-TC, CISCO-SMI, CISCO-TC Pre-compiled MIBs borrowed: Up to date MIBs: IANAifType-MIB, IF-MIB, INET-ADDRESS-MIB, SNMP-FRAMEWORK-MIB, SNMPv2-CONF, SNMPv2-MIB, SNMPv2-SMI, SNMPv2-TC Source MIB repositories: file:///usr/share/snmp/mibs, https://mibs.pysnmp.com/asn1/@mib@ Borrow missing/failed MIBs from: https://mibs.pysnmp.com:443/mibs/fulltexts/@mib@ Existing/compiled MIB locations: pysnmp.smi.mibs, pysnmp_mibs Compiled MIBs destination directory: /build/.pysnmp/mibs MIBs excluded from code generation: INET-ADDRESS-MIB, PYSNMP-USM-MIB, RFC-1212, RFC-1215, RFC1065-SMI, RFC1155-SMI, RFC1158-MIB, RFC1213-MIB, SNMP-FRAMEWORK-MIB, SNMP-TARGET-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC, SNMPv2-TM, TRANSPORT-ADDRESS-MIB MIBs to compile: TCP-MIB Destination format: pysnmp Custom destination template: None Parser grammar cache directory: not used Also compile all relevant MIBs: yes Rebuild MIBs regardless of age: no Dry run mode: no Create/update MIBs: yes Byte-compile Python modules: yes (optimization level no) Ignore compilation errors: no Generate OID->MIB index: no Generate texts in MIBs: yes Keep original texts layout: no Try various file names while searching for MIB module: yes Missing source MIBs: Ignored MIBs: Failed MIBs: Created/updated MIBs: TCP-MIB Pre-compiled MIBs borrowed: Up to date MIBs: INET-ADDRESS-MIB, SNMPv2-CONF, SNMPv2-SMI, SNMPv2-TC ============================= test session starts ============================== platform linux -- Python 3.14.8, pytest-9.1.1, pluggy-1.7.0 rootdir: /build/python-pysnmp/src/pysnmp-7.1.30 configfile: pyproject.toml plugins: asyncio-1.4.0 asyncio: mode=Mode.STRICT, debug=False, asyncio_default_fixture_loop_scope=None, asyncio_default_test_loop_scope=function collected 250 items tests/carrier/asyncio/test_dispatch.py ....... [ 2%] tests/carrier/asyncio/test_tcp.py ............... [ 8%] tests/carrier/asyncio/test_udp6.py ... [ 10%] tests/carrier/test_sockfix.py .. [ 10%] tests/entity/test_ipv6_zone.py .. [ 11%] tests/entity/test_vacm.py .... [ 13%] tests/hlapi/test_ipv6_zone_transport_target.py ... [ 14%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_slim.py .......... [ 18%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py ........ [ 21%] .F [ 22%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_next.py . [ 22%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py ... [ 24%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_walk.py .. [ 24%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2_walk.py ... [ 26%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulk.py .... [ 27%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py .. [ 28%] .............F..... [ 36%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_get.py ... [ 37%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_next.py . [ 37%] tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_set.py . [ 38%] tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py ... [ 39%] tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-inform.py . [ 39%] tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py ..... [ 41%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py . [ 42%] [ 42%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_lcd_configurator.py . [ 42%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_get.py ..... [ 44%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_next.py . [ 44%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_set.py ... [ 46%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_walk.py ... [ 47%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2_walk.py ... [ 48%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulk.py ..... [ 50%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py ......... [ 54%] ......F..... [ 58%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_get.py ... [ 60%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_next.py . [ 60%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_set.py .. [ 61%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_none_none.py .. [ 62%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes128.py .... [ 63%] [ 63%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes256.py ... [ 64%] tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_none.py ... [ 66%] tests/proto/secmod/test_rfc2786_dh.py .............. [ 71%] tests/proto/secmod/test_rfc3414_service.py . [ 72%] tests/proto/secmod/test_rfc3826_aes.py . [ 72%] tests/proto/test_malformed_response_handling.py .... [ 74%] tests/proto/test_named_bits.py ...... [ 76%] tests/proto/test_network_address.py ............ [ 81%] tests/proto/test_rfc1902.py ...... [ 83%] tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py . [ 84%] .... [ 85%] tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py . [ 86%] [ 86%] tests/smi/manager/test_mib-tree-inspection.py ....... [ 88%] tests/smi/test_builder_compilation_errors.py ...... [ 91%] tests/smi/test_if_mib_write.py .. [ 92%] tests/smi/test_inetaddress_index.py ...... [ 94%] tests/smi/test_mib_source_namespace_package.py ... [ 95%] tests/smi/test_rfc1902_is_fully_resolved.py . [ 96%] tests/smi/test_rfc2786_without_crypto.py .... [ 97%] tests/smi/test_snmpv2_smi_scalar_instance.py ..... [ 99%] tests/smi/test_transport_address_ipv6z.py . [100%] =================================== FAILURES =================================== _________________________ test_v1_get_multiple_objects _________________________ @pytest.mark.asyncio async def test_v1_get_multiple_objects(): async with AgentContextManager(enable_custom_objects=True) as agent: mib_builder = agent.get_mib_builder() (MibScalarInstance,) = mib_builder.import_symbols("SNMPv2-SMI", "MibScalarInstance") > (ifDescr,) = mib_builder.import_symbols("IF-MIB", "ifDescr") ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:281: _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ pysnmp/smi/builder.py:473: in import_symbols self.load_modules(modName, **userCtx) pysnmp/smi/builder.py:418: in load_modules self.load_module(modName, **userCtx) _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ self = modName = 'IF-MIB', userCtx = {} def load_module(self, modName, **userCtx): """Load and execute MIB modules as Python code.""" for mibSource in self.__mib_sources: debug.logger & debug.FLAG_BLD and debug.logger( f"loadModule: trying {modName} at {mibSource}" ) try: codeObj, sfx = mibSource.read(modName) except OSError: debug.logger & debug.FLAG_BLD and debug.logger( f"loadModule: read {modName} from {mibSource} failed: {sys.exc_info()[1]}" ) continue modPath = mibSource.full_path(modName, sfx) if modPath in self.__modPathsSeen: debug.logger & debug.FLAG_BLD and debug.logger( "loadModule: seen %s" % modPath ) break else: self.__modPathsSeen.add(modPath) debug.logger & debug.FLAG_BLD and debug.logger( "loadModule: evaluating %s" % modPath ) g = {"mibBuilder": self, "userCtx": userCtx} try: if __debug__: runpy.run_path( modPath, g ) # IMPORTANT: enable break points in loaded MIBs else: exec(codeObj, g) except Exception: self.__modPathsSeen.remove(modPath) raise error.MibLoadError( f"MIB module '{modPath}' load error: {traceback.format_exception(*sys.exc_info())}" ) self.__modSeen[modName] = modPath debug.logger & debug.FLAG_BLD and debug.logger( "loadModule: loaded %s" % modPath ) break if modName not in self.__modSeen: > raise error.MibNotFoundError( 'MIB file "{}" not found in search path ({})'.format( modName and modName + ".py[co]", ", ".join([str(x) for x in self.__mib_sources]), ) ) E pysnmp.smi.error.MibNotFoundError: MIB file "IF-MIB.py[co]" not found in search path (DirMibSource('/build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/mibs'), DirMibSource('/build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/mibs/instances'), DirMibSource('pysnmp_mibs')) pysnmp/smi/builder.py:394: MibNotFoundError __________________ test_v2c_get_table_bulk_partial_last_batch __________________ @pytest.mark.asyncio async def test_v2c_get_table_bulk_partial_last_batch(): async with AgentContextManager(): with SnmpDispatcher() as snmpDispatcher: max_repetitions = total_count // 2 + 1 objects = bulk_walk_cmd( snmpDispatcher, CommunityData("public"), await UdpTransportTarget.create(("localhost", AGENT_PORT)), 0, max_repetitions, ObjectType(ObjectIdentity("SNMPv2-MIB", "sysDescr", 0)), ) objects_list = [obj async for obj in objects] errorIndication, errorStatus, errorIndex, varBinds = objects_list[0] assert errorIndication is None assert errorStatus == 0 > assert len(varBinds) == max_repetitions E assert 64 == 107 E + where 64 = len((ObjectType(ObjectIdentity(, payload [1.3.6.1.2.1.1.2.0]>)...3648, 2147483647>, >>, payload [0]>), ...)) tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py:218: AssertionError __________________ test_v2c_get_table_bulk_partial_last_batch __________________ @pytest.mark.asyncio async def test_v2c_get_table_bulk_partial_last_batch(): async with AgentContextManager(): with SnmpEngine() as snmpEngine: max_repetitions = total_count // 2 + 1 objects = bulk_walk_cmd( snmpEngine, CommunityData("public"), await UdpTransportTarget.create(("localhost", AGENT_PORT)), ContextData(), 0, max_repetitions, ObjectType(ObjectIdentity("SNMPv2-MIB", "sysDescr", 0)), ) objects_list = [obj async for obj in objects] errorIndication, errorStatus, errorIndex, varBinds = objects_list[0] assert errorIndication is None assert errorStatus == 0 > assert len(varBinds) == max_repetitions E assert 64 == 107 E + where 64 = len((ObjectType(ObjectIdentity(, payload [1.3.6.1.2.1.1.2.0]>)...3648, 2147483647>, >>, payload [0]>), ...)) tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py:224: AssertionError =============================== warnings summary =============================== pysnmp/smi/compiler.py:23 /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/compiler.py:23: DeprecationWarning: getReadersFromUrls is deprecated. Please use get_readers_from_urls instead. from pysmi.reader.url import getReadersFromUrls pysnmp/smi/compiler.py:29 /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/compiler.py:29: DeprecationWarning: smiV1Relaxed is deprecated. Please use smi_v1_relaxed instead. from pysmi.parser.dialect import smiV1Relaxed ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:25 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:31 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:38 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:63 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:63: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. CIPsecTunnelStatus) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:25 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:31 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:38 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:48 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:48: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (ciscoMgmt,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:25 /build/.pysnmp/mibs/CISCO-SMI.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:31 /build/.pysnmp/mibs/CISCO-SMI.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:38 /build/.pysnmp/mibs/CISCO-SMI.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:49 /build/.pysnmp/mibs/CISCO-SMI.py:49: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:67 /build/.pysnmp/mibs/CISCO-SMI.py:67: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:86 /build/.pysnmp/mibs/CISCO-SMI.py:86: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-SMI.py:572 /build/.pysnmp/mibs/CISCO-SMI.py:572: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:53 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:53: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:71 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:71: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:90 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:90: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-IPSEC-TC.py:985 /build/.pysnmp/mibs/CISCO-IPSEC-TC.py:985: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:82 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:82: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (ciscoMgmt,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:87 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:87: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. CiscoPort) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:25 /build/.pysnmp/mibs/CISCO-TC.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:31 /build/.pysnmp/mibs/CISCO-TC.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:38 /build/.pysnmp/mibs/CISCO-TC.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:48 /build/.pysnmp/mibs/CISCO-TC.py:48: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (ciscoModules,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:53 /build/.pysnmp/mibs/CISCO-TC.py:53: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:72 /build/.pysnmp/mibs/CISCO-TC.py:72: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:92 /build/.pysnmp/mibs/CISCO-TC.py:92: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-TC.py:1395 /build/.pysnmp/mibs/CISCO-TC.py:1395: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:93 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:93: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ifIndex) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:25 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:31 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:38 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:48 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:48: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (IANAifType,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:25 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:31 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:38 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:49 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:49: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:67 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:67: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. mib_2) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:86 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:86: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IANAifType-MIB.py:855 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IANAifType-MIB.py:855: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( ../../../.pysnmp/mibs/IF-MIB.py:54 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:54: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectGroup) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:60 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:60: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (snmpTraps,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:81 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:81: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. mib_2) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:109 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:109: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TruthValue) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/IF-MIB.py:1434 tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_none tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py::test_send_v3_trap_notification_invalid_user tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py::test_custom_asn1_mib_search_path tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py::test_add_asn1_mib_source tests/smi/test_if_mib_write.py::test_write_if_entry_ifindex_no_error tests/smi/test_if_mib_write.py::test_write_if_entry_ifdescr_no_error /build/.pysnmp/mibs/IF-MIB.py:1434: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:99 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:99: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. InetAddressType) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:104 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:104: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (SnmpAdminString,) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:110 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:110: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectGroup) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:132 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:132: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:158 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:158: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TruthValue) = mibBuilder.importSymbols( ../../../.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:4064 /build/.pysnmp/mibs/CISCO-ENHANCED-IPSEC-FLOW-MIB.py:4064: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( tests/entity/test_vacm.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_slim.py: 10 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py: 7 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_walk.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2_walk.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulk.py: 4 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py: 21 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_get.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_set.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-inform.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_get.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_set.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulk.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py: 21 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_get.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_set.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_none_none.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes128.py: 4 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes256.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_none.py: 3 warnings tests/proto/test_network_address.py: 4 warnings tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py: 5 warnings tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py: 1 warning tests/smi/test_if_mib_write.py: 2 warnings /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/compiler.py:60: DeprecationWarning: addSources is deprecated. Please use add_sources instead. compiler.addSources( tests/entity/test_vacm.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_slim.py: 10 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py: 7 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_walk.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2_walk.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulk.py: 4 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py: 21 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_get.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_set.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-inform.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_get.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_set.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulk.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py: 21 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_get.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_set.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_none_none.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes128.py: 4 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes256.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_none.py: 3 warnings tests/proto/test_network_address.py: 4 warnings tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py: 5 warnings tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py: 1 warning tests/smi/test_if_mib_write.py: 2 warnings /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/compiler.py:64: DeprecationWarning: addSearchers is deprecated. Please use add_searchers instead. compiler.addSearchers(StubSearcher(*baseMibs)) tests/entity/test_vacm.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_slim.py: 10 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py: 7 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_walk.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2_walk.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulk.py: 4 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py: 21 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_get.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_set.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-inform.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_get.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_set.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulk.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py: 21 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_get.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_set.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_none_none.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes128.py: 4 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes256.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_none.py: 3 warnings tests/proto/test_network_address.py: 4 warnings tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py: 5 warnings tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py: 1 warning tests/smi/test_if_mib_write.py: 2 warnings /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/compiler.py:65: DeprecationWarning: addSearchers is deprecated. Please use add_searchers instead. compiler.addSearchers( tests/entity/test_vacm.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_slim.py: 10 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py: 7 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_walk.py: 2 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2_walk.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulk.py: 4 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py: 21 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_get.py: 3 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_next.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_set.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-inform.py: 1 warning tests/hlapi/v3arch/asyncio/agent/ntforg/test_v3-trap.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_custom_asn1_mib_search_path.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_get.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_set.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2_walk.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulk.py: 5 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py: 21 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_get.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_next.py: 1 warning tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_set.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_none_none.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes128.py: 4 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_aes256.py: 3 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v3_usm_sha_none.py: 3 warnings tests/proto/test_network_address.py: 4 warnings tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py: 5 warnings tests/smi/manager/test_convert-between-pdu-varbinds-and-mib-objects.py: 1 warning tests/smi/test_if_mib_write.py: 2 warnings /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/smi/compiler.py:68: DeprecationWarning: addBorrowers is deprecated. Please use add_borrowers instead. compiler.addBorrowers( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py: 7 warnings tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py: 1 warning tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_get.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v1_get.py: 2 warnings tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_get.py: 2 warnings /build/python-pysnmp/src/pysnmp-7.1.30/tests/agent_context.py:93: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:137: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mibBuilder) tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:141: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mibBuilder.loadModules("LEXTUDIO-TEST-MIB") tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:49: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:67: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:89: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_dateandtime_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/.pysnmp/mibs/LEXTUDIO-TEST-MIB.py:258: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:173: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mibBuilder) tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_physaddress_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:177: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mibBuilder.loadModules("LEXTUDIO-TEST-MIB") tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:209: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mibBuilder) tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_integer_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:213: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mibBuilder.loadModules("LEXTUDIO-TEST-MIB") tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:245: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mibBuilder) tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_scaled_unsigned_object /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py:249: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mibBuilder.loadModules("LEXTUDIO-TEST-MIB") tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py:40: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mibBuilder) tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py::test_v1_set_mac_address /build/python-pysnmp/src/pysnmp-7.1.30/tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_set.py:44: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mibBuilder.loadModules("LEXTUDIO-TEST-MIB") tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:49: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. InetAddressType) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:54: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (netSnmp,) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:49: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:67: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:86: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-MIB.py:191: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:58: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (SnmpAdminString,) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:63: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. NotificationGroup) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:81: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. iso) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:102: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( tests/hlapi/v3arch/asyncio/agent/ntforg/test_default-v1-trap.py::test_send_trap_custom_mib /build/.pysnmp/mibs/NET-SNMP-EXAMPLES-MIB.py:431: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( tests/proto/secmod/test_rfc2786_dh.py::TestDhCore::test_generate_key_pair_returns_integers tests/proto/secmod/test_rfc2786_dh.py::TestDhCore::test_shared_secret_symmetric tests/proto/secmod/test_rfc2786_dh.py::TestDhMib::test_auth_key_column_returns_agent_public_on_read tests/proto/secmod/test_rfc2786_dh.py::TestDhMib::test_dh_auth_key_exchange_updates_key tests/proto/secmod/test_rfc2786_dh.py::TestDhMib::test_wrong_agent_pub_raises tests/proto/secmod/test_rfc2786_dh.py::TestDhMib::test_second_read_returns_same_public_after_no_write tests/proto/secmod/test_rfc2786_dh.py::TestDhMib::test_read_after_write_returns_new_public /build/python-pysnmp/src/pysnmp-7.1.30/pysnmp/proto/secmod/rfc2786/__init__.py:184: CryptographyDeprecationWarning: Diffie-Hellman over finite fields (FFDH) is deprecated and support will be removed in a future release. Use a more modern key exchange algorithm. from cryptography.hazmat.primitives.asymmetric.dh import ( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv /build/python-pysnmp/src/pysnmp-7.1.30/tests/proto/test_network_address.py:52: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mib_builder) tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:25: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectIdentifier) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:31: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. (NamedValues,) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:38: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ValueSizeConstraint) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:50: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. InetPortNumber) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:58: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. ObjectGroup) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:80: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. mib_2) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:102: DeprecationWarning: importSymbols is deprecated. Please use import_symbols instead. TextualConvention) = mibBuilder.importSymbols( tests/proto/test_network_address.py::test_inet_address_ipv4_resolv tests/proto/test_network_address.py::test_inet_address_ipv6_resolv tests/proto/test_network_address.py::test_inet_address_roundtrip /build/.pysnmp/mibs/TCP-MIB.py:872: DeprecationWarning: exportSymbols is deprecated. Please use export_symbols instead. mibBuilder.exportSymbols( tests/proto/test_network_address.py::test_inet_address_ipv6_resolv /build/python-pysnmp/src/pysnmp-7.1.30/tests/proto/test_network_address.py:65: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mib_builder) tests/proto/test_network_address.py::test_inet_address_roundtrip /build/python-pysnmp/src/pysnmp-7.1.30/tests/proto/test_network_address.py:82: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mib_builder) tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer /build/python-pysnmp/src/pysnmp-7.1.30/tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py:108: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mib_builder) tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_integer /build/python-pysnmp/src/pysnmp-7.1.30/tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py:109: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mib_builder.loadModules( tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned /build/python-pysnmp/src/pysnmp-7.1.30/tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py:126: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mib_builder) tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_unsigned /build/python-pysnmp/src/pysnmp-7.1.30/tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py:127: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mib_builder.loadModules("LEXTUDIO-TEST-MIB") tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/python-pysnmp/src/pysnmp-7.1.30/tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py:144: DeprecationWarning: addMibCompiler is deprecated. Please use add_mib_compiler instead. compiler.addMibCompiler(mib_builder) tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py::test_syntax_fixed_length_octet_string /build/python-pysnmp/src/pysnmp-7.1.30/tests/smi/manager/test_configure-mib-viewer-and-resolve-pdu-varbinds.py:145: DeprecationWarning: loadModules is deprecated. Please use load_modules instead. mib_builder.loadModules( -- Docs: https://docs.pytest.org/en/stable/how-to/capture-warnings.html =========================== short test summary info ============================ FAILED tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v1_get.py::test_v1_get_multiple_objects FAILED tests/hlapi/v1arch/asyncio/manager/cmdgen/test_v1arch_v2c_bulkwalk.py::test_v2c_get_table_bulk_partial_last_batch FAILED tests/hlapi/v3arch/asyncio/manager/cmdgen/test_v2c_bulkwalk.py::test_v2c_get_table_bulk_partial_last_batch =========== 3 failed, 247 passed, 851 warnings in 2085.52s (0:34:45) =========== ==> ERROR:(B A failure occurred in check().(B  Aborting...(B ]3008;end=615d05ee038b4f22b7b3059d60fd5a1d\[!p]104\[?7h]3008;end=523c73245ab74561a8342e8f4d0b846c\==> ERROR:(B Build failed, check /var/lib/archbuild/extra-riscv64/felix-9/build(B [?12l[?25h[?12l[?25h]3008;end=c6e961ffe57348ef89500214495967c7\[?12l[?25hreceiving incremental file list python-pysnmp-7.1.30-1-riscv64-build.log python-pysnmp-7.1.30-1-riscv64-check.log python-pysnmp-7.1.30-1-riscv64-prepare.log sent 81 bytes received 6,612 bytes 2,677.20 bytes/sec total size is 73,483 speedup is 10.98